Welcome Guest! To enable all features please Login. New Registrations are disabled.

Notification

Icon
Error

Lee
#1 Posted : Monday, December 31, 2012 5:21:23 PM(UTC)
Lee



Joined: 12/31/2012(UTC)
Posts: 1

Hi,

I install and maintain Milestone installations for the company I work for so am pretty confident when it comes to setting up and configuring, etc. However I have a problem with my home setup that I can not seem to fathum...

Basically, I have XProtect Go with an Axis P series HD camera. If I browse to the camera direct, when there is motion, the image is smooth as you would expect. If I look at the camera image via the management application, the image is jumpy and when watching the camera via the client, it is jumpy. ie if someone walks from left to right, it kind of skips along.

If I go to playback mode and watch something back that's been recorded - that is smooth as well.

Any ideas? I'm really scratching my head with this...
Justin
#2 Posted : Wednesday, January 2, 2013 1:16:25 PM(UTC)
Justin



Joined: 4/10/2012(UTC)
Posts: 1,643

Thanks: 196 times
Was thanked: 415 time(s) in 375 post(s)
I would highly recommend following the below solution and definitely trying to disable the aero effects.

Keep us informed how you get on.

Description:

While viewing or reviewing video in XProtect® Smart Client, the application locks or shows freezing /stuttering video. These symptoms typically indicate that the system is running out of virtual memory or does not have the resources to display the number of video streams at the current frame rate/resolution.

Solution:

Consider using a 64-bit OS and installing the 64-bit Smart Client for better memory management.
If your system is running on Windows® 7, switch to the Windows Basic theme. This turns off Aero effects and frees up video memory.
Create more views with fewer cameras to reduce the load on the application and PC.
In XProtect Smart Client, in Advanced options set the Max decoding threads to Auto to improve performance on multi-core systems.
Kind regards

Justin

Please remember to thank people who assist you by using the thank option at the top of any useful posts.
Lee
#3 Posted : Thursday, April 18, 2013 4:08:51 PM(UTC)
Lee



Joined: 4/18/2013(UTC)
Posts: 2

Hi Justin

I too am having the same issue with viewing H.264 streams through the Smart Client. Even when simply viewing two full HD streams. I am running a decent spec i7, 64-bit PC, with 8GB RAM and dedicated GPU and these aren't under too much strain according to the system resource readings. However, I have followed the instructions below and disabled Aero but the live video is still very choppy. Performance is perfect when viewing HD MJPEG streams as expected,

We are hoping to demonstrate our cameras with Milestone at IFSEC, but this issue is hindering me at the moment. We can probably swith to MJPEG for the purposes of our demonstration, however, I am interested in trying to solve this one with an eye on the future as it will probably rear its head in on a site where MJPEG may not be practical.

Any ideas?

Regards

Lee

Originally Posted by: Justin Go to Quoted Post
I would highly recommend following the below solution and definitely trying to disable the aero effects.

Keep us informed how you get on.

Description:

While viewing or reviewing video in XProtect® Smart Client, the application locks or shows freezing /stuttering video. These symptoms typically indicate that the system is running out of virtual memory or does not have the resources to display the number of video streams at the current frame rate/resolution.

Solution:

Consider using a 64-bit OS and installing the 64-bit Smart Client for better memory management.
If your system is running on Windows® 7, switch to the Windows Basic theme. This turns off Aero effects and frees up video memory.
Create more views with fewer cameras to reduce the load on the application and PC.
In XProtect Smart Client, in Advanced options set the Max decoding threads to Auto to improve performance on multi-core systems.


Justin
#4 Posted : Thursday, April 18, 2013 8:59:31 PM(UTC)
Justin



Joined: 4/10/2012(UTC)
Posts: 1,643

Thanks: 196 times
Was thanked: 415 time(s) in 375 post(s)
Hi Lee,

I'm actually at IFsec this year on the Tuesday and Wednesday so hopefully i'll see you there! I'm intrigued myself for the unusual choppy performance, one thing do you see a single core being fully utilised? Also does it exibit the same behavior described i.e. the live is choppy the playback is not.

As a supporter I'm also bloody keen to get to the bottom of this!

If possible if the solution hasn't improved the situation at all it is probably a good idea to raise a support case directly.

I have something I'd love to try but it's only going to be possible via a direct support case I think, if it proves I'm wrong I'll post the "fix" directly.


Oh two other things, quite simple to confirm could you try using the 7.0c hotfix clients below (64bit ideally), could you try reducing the cores to one in Advanced options set the Max decoding threads to 1 and confirm there is no improvement.

http://download.mileston...Build_701_x86_HOTFIX.zip
http://download.mileston...Build_701_x64_HOTFIX.zip



Kind regards

Justin

Please remember to thank people who assist you by using the thank option at the top of any useful posts.
Lee
#5 Posted : Friday, April 19, 2013 11:09:12 AM(UTC)
Lee



Joined: 4/18/2013(UTC)
Posts: 2

Originally Posted by: Justin Go to Quoted Post
Hi Lee,

I'm actually at IFsec this year on the Tuesday and Wednesday so hopefully i'll see you there! I'm intrigued myself for the unusual choppy performance, one thing do you see a single core being fully utilised? Also does it exibit the same behavior described i.e. the live is choppy the playback is not.

As a supporter I'm also bloody keen to get to the bottom of this!

If possible if the solution hasn't improved the situation at all it is probably a good idea to raise a support case directly.

I have something I'd love to try but it's only going to be possible via a direct support case I think, if it proves I'm wrong I'll post the "fix" directly.


Oh two other things, quite simple to confirm could you try using the 7.0c hotfix clients below (64bit ideally), could you try reducing the cores to one in Advanced options set the Max decoding threads to 1 and confirm there is no improvement.

http://download.mileston...Build_701_x86_HOTFIX.zip
http://download.mileston...Build_701_x64_HOTFIX.zip





Thanks Justin! I will give this a try and let you know how I get on.

Lee
San
#6 Posted : Wednesday, July 16, 2014 6:34:47 PM(UTC)
San



Joined: 10/24/2012(UTC)
Posts: 4

Thanks: 1 times
Hi.

I know this is a very old post, but I just wanted to know if there's a good solution for the live stuttering.. We've seen this very often, even with the 2014 suite, for example Enterprise 2014 with SC 2014 x64 running on the same system and a different remote pc as well. I've installed just one camera, an Axis P1355 720p@ 8 - 20fps. I used a dedicated Netgear 8 ports POE switch, both VMS and remote PC are connected to the switch as well as the camera. When I'm viewing the live stream from the camera's website it gives me a fluid stream, but viewing the stream in the client it stutters. It runs smoothly for a little more then a second, then it hangs for a fraction of a second, then it runs smoothly again for a big second and so it goes on. It looks like it's buffering data and is running full, then clears the buffer again and so on.

Like the first post said, playing back runs fine.

Thanks,
San
Justin
#7 Posted : Thursday, July 17, 2014 4:54:08 PM(UTC)
Justin



Joined: 4/10/2012(UTC)
Posts: 1,643

Thanks: 196 times
Was thanked: 415 time(s) in 375 post(s)
Well theres a couple of things you can do which may help.

Description:

While viewing or reviewing video in XProtect® Smart Client, the application locks or shows freezing /stuttering video. These symptoms typically indicate that the system is running out of virtual memory or does not have the resources to display the number of video streams at the current frame rate/resolution.

Solution:

Consider using a 64-bit OS and installing the 64-bit Smart Client for better memory management.
If your system is running on Windows® 7, switch to the Windows Basic theme. This turns off Aero effects and frees up video memory.
Create more views with fewer cameras to reduce the load on the application and PC.
In XProtect Smart Client, in Advanced options set the Max decoding threads to Auto to improve performance on multi-core systems.


We also have a new 9.0a Smart client which solves a number of issues which "could" help.

Description:

Multicast streaming causing Smart Client to use increasing memory, which leads to increasingly bad performance and crashes.
Map issues with ghosting of elements and renaming of elements in the map.
Joystick - dead zone configuration not consistent.
"OK" and "Cancel" buttons missing on the Privacy Mask window.
Matrix Messages causing crashes.
Poor performance (stuttering) in playback mode.
Out of memory crashes.

Solution:

A new hot-fixed version of the Smart Client 2014 is available

Download and then use this installer in each client PC with 32 bit Windows:
http://download.mileston...eXProtectSmartClient.exe
For PCs capable of 64 bit: (Has a 64 bit Windows)
http://download.mileston...otectSmartClient_x64.exe

Kind regards

Justin

Please remember to thank people who assist you by using the thank option at the top of any useful posts.
 1 user thanked Justin for this useful post.
Salim on 7/23/2014(UTC)
Users browsing this topic
Guest (3)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.