Welcome Guest! To enable all features please Login. New Registrations are disabled.



#1 Posted : Monday, October 27, 2014 7:00:53 PM(UTC)

Joined: 5/27/2014(UTC)
Posts: 0

Found this on the forum:

If you are in the process of adding a camera to XProtect and you find that you are unable to complete the process, there are a few troubleshooting steps to check over:

Yes - 1) Ensure that the network device is supported by Milestone XProtect software. You can review the supported hardware list here: http://www.milestonesys....pport/supported+hardware

Yes - 2) Ensure you have the latest Device Pack installed. The Device Pack is a collection of network device drivers that Milestone bundles with its XProtect software. Having the latest Device Pack ensures that you have the most stable, robust connection to your network devices that XProtect can offer. The Device Pack can be downloaded from http://www.milestonesys.com/downloads.

Yes - 3) Ensure the device is online and available over your network. From the recording server computer, you should be able to ping the camera's IP address and also visit its web management interface in a web browser. If the device is listening on a special port number, you should know what this is and be able to specify it in the connection address.

Yes - 4) Ensure that you can pass the camera's authentication process. You should know what the camera's Administrator account user name and password is. You should have full Administrator access to all parts of the cameras web management interface.

Yes - 5) Try disabling Windows Firewall on the recording sever as a troubleshooting step. It can interfere with the hardware detection process under rare circumstances.

Yes - 6) If you are using XProtect Enterprise, Professional, Essential, or Go, try leaving the user name drop-down menu set to 'default'. The reason for this is that many XProtect camera drivers will automatically supply a pre-specified user name (to maintain compatibility with older versions of XProtect). Leaving the user name menu set to 'default' will ensure that the device driver does not send the user name twice when authenticating to the device. NOTE: Make sure that the device's Administrator account user name is set to the specified user name listed on the XProtect supported hardware list.

Yes - 7) Ensure that the firmware loaded on the camera is listed as a 'tested' firmware on our supported hardware list. The device firmwares we list as tested have gone through our QA process and we have verified those as working with our drivers.

8) If you have accounted for all of this, and you still are not able to add the device, please let us know.

Not sure what else to check???
#2 Posted : Tuesday, October 28, 2014 4:45:42 PM(UTC)

Joined: 4/23/2012(UTC)
Posts: 317

Thanks: 1 times
Was thanked: 95 time(s) in 88 post(s)
Hi Kaelen,

If you could reveal a bit more, like what device brand/model/firmware and what exact version Device Pack (from appwiz.cpl; example v. 7.5.1812) and what version/edition of the XProtect® Professional you using, I will give it my best shot.
Also, if you're using the "Replace hardware" or adding a new device on a new IP-address.
Best regards,

Michael W.
Milestone technical support
#3 Posted : Tuesday, October 28, 2014 5:43:57 PM(UTC)

Joined: 5/27/2014(UTC)
Posts: 0

Sure Michael. Not a problem. Thanks ahead of time for the help!

- Brand new Axis P3214-V dome camera, firmware version, nothing complicated or fancy in the setup with just your standard ip address, x.x.x.30,, x.x.x.1(gateway).
- It is accessible from the server via a web browser and everything seems to be functioning fine camera wise.
- It is pingable across the network as well.

- Milestone system is XProtect Express 2014, Version 8.6a, device pack 7.3.1541, build 241983

- So here's the whole story that I'll try to make brief. We have 39 licenses/cameras, 1 camera has failed. I'm replacing that camera with the P3214-v dome camera. I originally tried "replacing the hardware" and that didn't work. I then deleted the camera under advanced configuration by right mouse clicking and "delete this hardware device." Then saved the configuration. Next I plugged in the new camera on the network after configuring the ip address, used "add hardware", "manually specify the hardware to add" option, entered the ip address/port/username/password/auto-detect. It can't find the camera and times out. Tried scanning option, didn't work. The only thing that gets close to working is manually selecting the driver, "z(legacy)universal driver". It'll find the camera and add it, but won't show a picture or function properly.

- Let me know if I'm just an idiot and missing something simple. We only have Axis cameras and I've been managing them for a little over 4 years... no issues before with your software or the Axis cameras...
#4 Posted : Tuesday, October 28, 2014 6:24:26 PM(UTC)

Joined: 6/13/2012(UTC)
Posts: 20

Thanks: 12 times
Was thanked: 1 time(s) in 1 post(s)
Hi Kaelen, have you tried manually selecting the z(Legacy) AXIS M3xx3/4/5 Driver instead of the latest AXIS 1 Channel Driver ? I have solved a few compatibility problems that way.
Kind regards,
#5 Posted : Tuesday, October 28, 2014 6:59:18 PM(UTC)

Joined: 5/27/2014(UTC)
Posts: 0

Just did and it immediately goes to "unable to connect, check username and password. I even tried just leaving the username/password defaulted.
#6 Posted : Wednesday, July 29, 2015 3:00:34 AM(UTC)

Joined: 9/18/2013(UTC)
Posts: 0

Hi Kaelen

were you able to find a proper solution for the issue that you had?



Saif N
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.