Welcome Guest! To enable all features please Login. New Registrations are disabled.

Notification

Icon
Error

Jereme
#1 Posted : Tuesday, January 6, 2015 9:58:21 AM(UTC)
Jereme



Joined: 1/6/2015(UTC)
Posts: 10

Thanks: 3 times
Was thanked: 6 time(s) in 5 post(s)
Hi All,

I've been trying to get some of my low end DLink cameras to work with XProtect Go. I have been successful getting their feeds in iSpy, BlueIris, VLC, and the D-ViewCam. However, for some reason I can not get them to work with XProtect.

After trying many different settings, and searching the web for hours, I finally decided to try Wireshark. I am no expert with wireshark by any means, but it seemed to me that XProtect was failing to add the correct port to the request URL even though I had specified a port when setting up the camera. So I tried setting the port back to port 80 on the camera itself, but it seemed to have no effect.

In XProtect I have tried many combinations, and am currently trying:
Code: JPEG
Streaming Mode: HTTP
Delivery Mode: Multipart stream
Retrieval mode: Snapshot
Connection URI: mjpeg.cgi

I realise these are two different IPs, I was capturing data using two different cameras to make it easier to filter through the results in Wireshark. However, all the cameras work with BlueIris. (Yes I changed IPs and passwords for this post)

XPROTECT (Doesn't Work):
GET /mjpeg.cgi HTTP/1.1\r\n
User-Agent: HTTP Image Reader\r\n
Connection: Keep-Alive\r\n
User-Agent: HTTP Image Reader\r\n
Authorization: Basic YWRtaW46Q2VyZ==\r\n
Credentials: admin:password
Full request URI: http://192.168.1.17/mjpeg.cgi

BLUEIRIS (Works):
GET /mjpeg.cgi HTTP/1.1\r\n
User-Agent: BlueIris\r\n
Connection: Keep-Alive\r\n
Authorization: Basic YWRtaW46Q2=\r\n
Credentials: admin:password
Full request URI: http://192.168.1.18:818/mjpeg.cgi

I am guessing the port issue is either a non issue and me just reading wireshark wrong, or a bug in the XProtect software. However, is there something else I might be doing wrong to cause it to not connect in XProtect?
Jereme
#2 Posted : Tuesday, January 6, 2015 10:13:02 PM(UTC)
Jereme



Joined: 1/6/2015(UTC)
Posts: 10

Thanks: 3 times
Was thanked: 6 time(s) in 5 post(s)
I have solved this issue:

Turns out there are quite a few settings that actually do work with XProtect. However, XProtect does seem to have a flaw in that it cannot correctly pass authentication to the DLink camera.

The biggest change I needed to make was turning off UAC as this post suggested. It is found on the Maintenance tab of the DCS-930L and DCS-932L cameras under Server Settings, it is called User Access Control. By disabling this feature I believe you are turning off the ability to have multiple user accounts on the camera itself, a nice feature being lost, but in my case I can live without it.

Once that change has been made on the camera, specific ports do seem to work just fine. Specific ports are nice if you want direct access to the cameras through your firewall, in my case so the DLink mobile app doesn't time out.

The Settings in XProtect that I have found to work the best are:
Codec: JPEG
Streaming mode: HTTP
Delivery mode: Non multipart stream
keep alive type: Default (greyed out)
Retrieval mode: Snapshot
Connection URI: image/jpeg.cgi

Other delivery modes, retrieval modes, and URI's do work, however the ones I tried caused a great deal of jerkiness to be introduced into the stream.
 1 user thanked Jereme for this useful post.
Justin on 1/7/2015(UTC)
Jereme
#3 Posted : Thursday, January 8, 2015 5:33:27 AM(UTC)
Jereme



Joined: 1/6/2015(UTC)
Posts: 10

Thanks: 3 times
Was thanked: 6 time(s) in 5 post(s)
After solving the basic connection issue I have moved on to trying to get the cameras microphone to work with XProtect.

Using VLC I discovered that the camera is serving up an audio stream using the codec PCM S16 le.

Based on this page, it seems as if the closest thing XProtect has would be PCM RAW; does anyone out there familiar with audio know if XProtect is capable of accepting this codec? Or am I out of luck? So far none of the configurations I have tried have produced audio or stopped the lost connection flashing which I would assume would mean it was finally getting an audio stream.
Torsten
#4 Posted : Thursday, January 8, 2015 11:35:32 AM(UTC)
Torsten



Joined: 2/11/2013(UTC)
Posts: 451

Thanks: 28 times
Was thanked: 127 time(s) in 119 post(s)
As far as I know Milestone only supports the good old G.711 (don't know if it is µ-law or a-law).

Rgds,
Torsten
Jereme
#5 Posted : Thursday, January 8, 2015 5:38:05 PM(UTC)
Jereme



Joined: 1/6/2015(UTC)
Posts: 10

Thanks: 3 times
Was thanked: 6 time(s) in 5 post(s)
I'll double check when I get home, but i'm pretty sure the Universal Driver allows me to select from more than just a G.711 codec. According to KB197 "There are 19 supported codecs".

I've currently got my camera set to PCM RAW since that was the closest match I could find. I did try the PCM u-law and PCM a-law's as well with no success. It makes me wonder if there is another setting on the camera I have to tweak to let XProtect in.

Edited by user Thursday, January 8, 2015 5:40:29 PM(UTC)  | Reason: add current configuration

Jereme
#6 Posted : Saturday, January 10, 2015 1:25:13 AM(UTC)
Jereme



Joined: 1/6/2015(UTC)
Posts: 10

Thanks: 3 times
Was thanked: 6 time(s) in 5 post(s)
I can select from:
PCM RAW
PMC mju-law
PCM A-law
G.711 mju-law
G.711A-law

G.721... and variations
G.723.... and variations
G.726.... and variations

So lots of choices. I think PCM RAW is the right one from all the research I have done. Once I even thought I heard a peep from the microphone, but it must have been my imagination as I was unable to re-create it.
Patrick
#7 Posted : Saturday, July 4, 2015 8:17:47 PM(UTC)
Patrick



Joined: 7/4/2015(UTC)
Posts: 1

Jereme,

Thanks for posting all the details on the DCS-930L. I have set my settings as you posted, and I am successfully viewing the camera in the "Management Application." However, I'm having no luck viewing the images in the Smart Client.

The error message "The server has lost connection to the camera." is displayed. Have you seen this with your camera?

Any help you can provide would be very much appreciated.

Thanks,
Patrick M.
Jereme
#8 Posted : Saturday, July 4, 2015 8:42:18 PM(UTC)
Jereme



Joined: 1/6/2015(UTC)
Posts: 10

Thanks: 3 times
Was thanked: 6 time(s) in 5 post(s)
There are two things I have found that can cause that Patrick.

First is, make sure your microphone is disabled in the Management application, it should have a listing right under your camera.

I have never been successful in making my microphone work, and the more into security systems I have gotten I have found that these DLink cameras are really bottom end, the only thing they are good for is remotely listening in on conversations through the DLink app; but since they do not support the H.264 video encoding format they take up far too much disk space when recording.

I recently ran into another issue that cause the lost connection error. I switched to a new server, and even with a backup and restore of my XProtect config file not everything made it over correctly. The views (even the default view) in the Smart Client was one such victim. By editing the default view, deleting and then re-adding all the cameras to it I was able to correct the problem.
Users browsing this topic
Guest (3)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.