I got two customer systems having problem connecting to the XProtect message communication system.
My plugin is a event server plugin and normally MessageCommunicationManager.Get(ServerId).IsConnected will return true directly when initializing the plugin are shortly thereafter. But on these systems, IsConnected returns false indefinitely.
We already employ the pattern from this post, i.e. waiting for the ConfigurationChangedIndication event to trigger before starting MessageCommunicationManager. We also make sure MessageCommunicationManager.Get(ServerId).IsConnected is true before registering the communication filter.
What could be the reason for IsConnected never turning true? I’m starting to think this is a configuration problem on these specific systems. Is there something I could check/log to determine the reason for this?
I got the event server logs from one of the systems but the only things that stand out (to me) are these log lines:
FeatureManager Error opening VMO connection to: :80 with message: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '…
[…]
VmsAddressResolver EventStatusSubscription error: Could not get management server URIs from address: http:///managementserver/.Well-known/uris. HttpRequestException: Response status code does not indicate success: 500 (Internal Server Error).
VmsAddressResolver Identity Provider address set to: http:///IDP
[…]
LogMessagesUpdater Error uploading audit log languages definition files with error message: LogServer address not available.
Exception details:
VideoOS.Management.VmoClient.DeviceNotFoundException: LogServer address not available.
at VideoOS.Event.Server.Utils.AuditLog.LogMessagesUpdater.d__4.MoveNext()
Which versions are the two VMS systems running? Are they on the same version/build?
Are both systems updated with the latest available patch for that version?
Both customer seems to be running 2025 R3 and the first claims that latest patches has been deployed. The event server logs reports these versions:
Version: 25.3.19877.1
Version: 25.3.19928.1 (no information on patches)
Correct. MCC-2036 is the one.
Event Server 25.3.17737.1 is the initial release version which did not have the issue. It turns out that Milestone introduced a bug in one of the patches.
So the issue is in a patched 2025R3, and never in other versions.