MessageCommunicationManager.Get(ServerId).IsConnected returning false

Hi,

I got two customer systems having problem connecting to the XProtect message communication system.

My plugin is a event server plugin and normally MessageCommunicationManager.Get(ServerId).IsConnected will return true directly when initializing the plugin are shortly thereafter. But on these systems, IsConnected returns false indefinitely.

We already employ the pattern from this post, i.e. waiting for the ConfigurationChangedIndication event to trigger before starting MessageCommunicationManager. We also make sure MessageCommunicationManager.Get(ServerId).IsConnected is true before registering the communication filter.

@Bo_Ellegard_Andersen

What could be the reason for IsConnected never turning true? I’m starting to think this is a configuration problem on these specific systems. Is there something I could check/log to determine the reason for this?

I got the event server logs from one of the systems but the only things that stand out (to me) are these log lines:

FeatureManager Error opening VMO connection to: :80 with message: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '…

[…]

VmsAddressResolver EventStatusSubscription error: Could not get management server URIs from address: http:///managementserver/.Well-known/uris. HttpRequestException: Response status code does not indicate success: 500 (Internal Server Error).
VmsAddressResolver Identity Provider address set to: http:///IDP

[…]

LogMessagesUpdater Error uploading audit log languages definition files with error message: LogServer address not available.
Exception details:
VideoOS.Management.VmoClient.DeviceNotFoundException: LogServer address not available.
at VideoOS.Event.Server.Utils.AuditLog.LogMessagesUpdater.d__4.MoveNext()

Which versions are the two VMS systems running? Are they on the same version/build?
Are both systems updated with the latest available patch for that version?

Both customer seems to be running 2025 R3 and the first claims that latest patches has been deployed. The event server logs reports these versions:
Version: 25.3.19877.1
Version: 25.3.19928.1 (no information on patches)

I have reported this as a bug to Milestone Development, I will update you here when I get feedback.

Thank you, but are you sure this is a bug? Can you reproduce?

By the way, I can’t reproduce this problem on my system and apparently I’m running a similar version of the event server: 25.3.17737.1

No, not sure at all this is a bug, but I expect to get help on how to troubleshoot based on the report to Development.

The feedback from Milestone Development is clear; we believe this is a bug, and fortunately one that has been recently fixed.

A fix has been developed. The fix comes in the from of a new Event Server 2025 R3 patch. Please download and apply the newest patch.

You can find it here: https://support.milestonesys.com/article/XProtect-2025-R3-cumulative-patch-installers?lang=en_US (under MyMilestone partner login).

I will appreciate your feedback when you have tested with this patch.

1 Like

Thanks a lot for the good news! I’ll be sure to update you as soon as either of the customers have evaluated the patch.

Hi again, one of the customer reported that the patch solves the problem. Thank you!

Is this the fix we’re looking for?
MCC-2036 - 19/08/2026 - Fixed an issue where loginSettings are not populated during the initial call

Can you explain why my developer system (event server 25.3.17737.1) is not affected?

I’m preparing some information about this problem. Are there other versions of XProtect, other than 25.R3 that is affected by this bug?

Correct. MCC-2036 is the one.
Event Server 25.3.17737.1 is the initial release version which did not have the issue. It turns out that Milestone introduced a bug in one of the patches.
So the issue is in a patched 2025R3, and never in other versions.

1 Like